Question:

The Backlot UI doesn't look correct, seems to be missing some elements, or isn't working as expected. What should I do?

Answer:

From time to time, we receive reports of strange behavior in Backlot, such as blank pages or pages that aren't loading fully, elements missing on one or more pages, areas of pages that aren't rendering properly, etc.

Here are a few things to check:

  1. All areas of Backlot require Google Chrome. If you are using any other browser, behavior may be unpredictable, or Backlot may not function at all.
  2. If the incorrect behavior is occurring in Google Chrome, try the following steps, in this order:
    • Log out of Backlot and log back in.
    • Clear your cache and cookies in Chrome. Instructions for how to do this can be found here.
    • Create a new "person" in Chrome (i.e. a new browser profile). This can be done by clicking the Chrome menu -> Settings -> Add person. By doing this, you are starting with a completely blank slate, with none of the extensions that are installed for your default profile.
  3. Try another computer, if available. This can help confirm or rule out something specific to your regular computer. If you are on a laptop, you may also try connecting to your company's guest WiFi network to see if it has something to do with your corporate WiFi environment. Another option is to try logging in to Backlot on your home computer to see if there is a difference.
  4. Have a different person try the same steps with their Backlot account, if available. This can help confirm or rule out something specific to your account. If the other person is not experiencing the issue, you can compare account settings on the My Account page, including roles/profiles added for each account, the countries list, etc.
  5. If the problem is reproducible on a different computer and with other Backlot accounts, check the version of Google Chrome and the version of Mac OS X or the Windows version. Frequently, all computers in an enterprise will have a standard configuration, and if the setup is dated, it could be problematic. We require a relatively recent (within six months) version of Google Chrome, and sometimes on older OS versions, Chrome will stop receiving automatic updates. Speak with your IT department for further instructions on how to address this.

If all of these fail to resolve your issue, please SUBMIT A REQUEST and we will assist you. Be sure to choose Backlot Support when submitting your ticket. 

Was this article helpful?
0 out of 1 found this helpful